welcome to cypress editor documentation

CypressEditor.Editor

The editor has a lot of features that help you writing and managing your code easily. Some of them located in Editor Toolbar, some in Editor Context Menu, some in Editor Tab's Context menu and for more comforting, some located in all those places.
For example, Run command is located in all places and is accessible from everywhere, as well as, keyboard shortcut F5.

CypressEditor.Editor.Editor Context Menu

When you right-click in the editor, you will see a pop-up menu includes some commands: editor context menu As you can see, there are some commands that are very familiar to Windows users (e.g. Cut, copy, paste ...). Also, Run command appears as the first command, for more comforting. Below is the list of commands and a simple word of what they do:
Below is the list of commands and a simple word of what they do:
Command Description Eq. Shortcut
Run Runs the file that is currently open in editor. F5
Undo Undo last changes, if available Ctrl + Z
Redo Redo last changes, if available. Ctrl + Y
Cut Cuts selected range of text to clipboard. Ctrl + X
Copy Copies selected range of text to clipboard. Ctrl + C
Paste Pastes text from clipboard to the editor at the caret position. Ctrl + V
Selects All Select all text in the editor. Ctrl + A
Comment Selection Comments selected range of code in the editor, if no text is selected, it comments the line that the caret is located at. Typically, puts a # sign at the beginning of each lines. Ctrl + K
Un-Comment Selection un-comments selected range of code in the editor, if no text is selected, it un-comments the line that the caret is located at. Typically, remove the # sign from the beginning of each line. Ctrl + Shift + K
Save Saves the file that is currently open in the editor. Note that if the content of file is changed, a * appears next to the tab title. When you save the file, this * will be removed. Ctrl + S
Export Exports the currently open file into two formats, RTF or Html. Not available
Zoom Zoom-in, Zoom-out and reset zoom. Also, you may change zoom by pressing and holding Ctrl and mouse wheel. Not available
Print Print the code file that is currently open in the editor to the printer. Ctrl + P
Display invisible Chars When you are writing you code, there are some places you pressed Enter key or Space key. This command shows you where you did that. It's is a useful option to reduce the size of file or remove white spaces. Not available
Show Document Map It makes easier to scroll up and down in a large file. By activating this option, a small preview of your file will be appear to the right side of the editor, where you could scroll up and down easily. Not available
Tips: You do not need to save your file(s) before RUN, every time. Cypress does it for you.
Tips: There is an option allows you to save all of your files included in a solution to be saved before run. For more info, see Options.

CypressEditor.Editor.Editor Toolbar

These commands are the same as Context Menu Commands with two exceptions, Add Tcl File and Open Existing Item. You could add Tcl files to your solution with two options:
  • Add a new Tcl file
  • Add an existing Tcl File
Add a new Tcl file:
Adds a new tcl file to you solution. It is a blank file or, you may use a template to fill it.
Add an existing Tcl File
This option allows you to add an existing tcl file to your solution.
If you click on Add New Tcl File or press Ctrl + N, the Add New Tcl File dialog will be displayed. In this window, you could add a defined template, if any, or pick a blank file type. If you click on a template in the Template Box, you will see a short description of the selected template.
Also you need to choose a unique name for your file. This name must be unique in the current solution. Simply, a solution could NOT contains files with same names, moreover, special chars are not allowed in the file name.
You will learn more about template in Option Menu.
Open Command: You may open a tcl file that is not include as one of your solution files. It will be opened in editor and run as a separated file.

CypressEditor.Editor.Editor Tab's Context Menu

If you right-click on the editor tab, a simple pop-up menu appears.
Command Description Eq. Shortcut
Save Saves the file that is currently open in the editor. Note that if the content of file is changed, a * will appears next to the tab title. When you save the file, this * will be removed. Ctrl + S
Save As ... Saves the file that is currently open in the editor at different location and/or with a different name. Also you may change the extension of file to txt where you need. (tcl and txt file extension are available). Not available
Close Closes the file taht is currently open in the editor. Not available
Close All But This Closes all the files that are open in the editor, except current file. Not available
Run Runs current file that is open in editor F5
Open containing Folder Opens the containing folder of currently open file, with Windows Explorer. Not available
Include in solution This command is available only if the current file is not a member of your solution files. This command adds an external file to your solution and makes it one of its files. Not available

CypressEditor.Editor.IntelliSense

From Microsoft, it means:
IntelliSense is the general term for a number of features: List Members, Parameter Info, Quick Info, and Complete Word. These features help you to learn more about the code you are using, keep track of the parameters you are typing, and add calls to properties and methods with only a few keystrokes. Many aspects of IntelliSense are language-specific.
As is clear, the IntelliSense of Cypress Editor is not complete and perfect as for example Visual Studio. It's only the beginning of the road. But I will do my best to improve it :)
When you are writing you code, where you type 2 first chars of a word, the IntelliSense menu will appear and shows you a list of all cantoning words that begin with what you typed and you may choose the word that you plan to write, in correct spell. It's easy as press Enter or Tab key. That's it.
You could scroll up and down in the list.
Every time that you press Ctrl + Space, the IntelliSense menu will appear with all the commands and keywords.

CypressEditor.Editor.Editor Tooltip

If you move mouse pointer over a keyword for a while, a tooltip will appear that contains some help tips about a keyword or command. If the keyword is an OpenSees command, it includes command syntax and arguments.

CypressEditor.Editor.Code Folding

Code folding is a useful option that allows you to collapse/expand a block of code between { and }. It helps you to expand or collapse some part(s) of your code to improve the visibility.
Unfolded if block Folded if block
When you write well-formed codes, a little - sign will be located every where that code folding option is available. It's just enough to click that - sign to fold and + sign to unfold a block of code.

CypressEditor.UI.Output Console

In addition to the classic DOS command prompt window, Cypress has an advanced internal output console. You can choose this behavior and switch between classic and internal console by using Options menu.
The Internal Console will close with pressing any key just like classic output window, but with some additional options:
  • Save output results as a text file.
  • Print output results to the printer or a file.
These simple options are available in context menu where you right-click on the console area.
Consider that there is a simple tcl file that includes one line of code:
puts "Hello word!"
So by using Run command, we will have:
Tips: As all other types of Cypress's windows, output console window could be docked too, where ever you want.

CypressEditor.UI.Menu.File Menu

This menu and sub menu items are familiar to Windows users.
Command Description Eq. Shortcut
Create New Solution Creates a new solution with a blank tcl file on the specified location. By using this command, Create New Solution dialog will be shown. After choosing a name for solution, you should specify a location on your hard drive by clicking on Browse... button.
Warning: Special chars are not allowed for solution name!
Tips: Consider that you want to create a solution named My2D_Braced located at C:\OpenSeesSolutions\. So, set the solution name as My2D_Braced in the name box and browse to C:\OpenSeesSolution. Then Cypress Editor creates a solution with this absolute path: C:\OpenSeesSolutions\My2D_Braced\My2D_Braced.osproj.
After that, all the solution's files located at this path.
Ctrl + Shift + N
Open Existing Solution Opens an existing solution.
Tips: When you open a solution, all files that you left open in the last session, will be opened on the editor. If there were not files open in the editor, the startup file will be opened.
Tips: Each solution has a startup file. This file is highlighted and bolded in Solution Explorer. This is an entry point of the solution. User may change the startup file of solution.
Ctrl + Shift + O
Open Existing Tcl File Opens an existing tcl file. This command is helpful when solution does not have file in editor and hence, the toolbar is not accessible. Not available
Import SAP2000 Model This command imports the structures that already modeled in SAP2000. This command is still under construction and coming up on the future versions. Not available
Convert to Cypress Solution This command converts your old OpenSees files to a CypressEditor solution. By using this command, Convert to Cypress Solution dialog will be shown.
Tips: You must to put all of your files in a folder, then start convert that folder.
Browse to the folder that contains your old files. All Tcl files will be listed. Choose a name for your solution and then select a file from left list as the startup file, then click Convert button.
If you check the Open this solution after conversation, so current solution will be closed, if any, and the new converted solution will be replaced.
Not available
Close Current Item This command closes the currently open file in editor, if any. Non
Close Solution This command closes the current solution and keep CypressEditor open so you may open or create another solution. Not available
Save Current Item This command saves the currently open file in the editor, if any. Ctrl + S
Save Current Item As... This command saves the currently open file in the editor as a tcl or txt file format at the specified path , if any. Not available
Save All This command saves all changed files. Ctrl + Shift + S
Print This command prints the file that is currently open in the editor, to printer. Ctrl + P
Exit Cypress This command exits application. Not available
Tips: You may find some of these items disabled. Menu items behavior depend on the type(extension) of file that open in the editor.

CypressEditor.UI.Menu.Edit Menu

This menu contains some familiar Windows commands such as Cut, Copy, Paste, Select All and so on.
You can refer to Editor Context menu section for more info.
Command Description Eq. Shortcut
Undo This command is used to undo last changes, if available Ctrl + Z
Redo This command is used to redo last changes, if available Ctrl + Y
Cut This command is used to cut selected range of text and set it to clipboard. Ctrl + X
Copy This command is used to copy selected range of text and set it to clipboard. Ctrl + C
Paste This command pastes text from clipboard to the editor at the caret position. Ctrl + V
Select All This command selects all text in the editor. Ctrl + A
Delete This command deletes selected text in the editor. Shift + Del
Find This command shows the Find Dialog and searches for a specified keyword. Ctrl + F
Replace This command shows the Replace Dialog and searches for a keyword and replace with another keyword. Ctrl + H

CypressEditor.UI.Menu.View Menu

These commands help you to control the visibility of panes.
Command Description Eq. Shortcut
Solution Explorer If the Solution Explore pane is closed, this command is enabled. This command shows the solution explore pane. F2
Command Explorer If the Command Explore pane is closed, this command is enabled. This command shows the Command Explore pane. F3
Command Help If the Command Help pane is closed, this command is enabled. This command shows the Command Help pane. F4
Show Output File This command shows the output files, *.txt or *.out in the editor. So you don’t need to use an external app. Not available

CypressEditor.UI.Solution Explorer

This window includes all solution files and let you to manage them fast and easy. There are some commands in the top toolbar:
Command Description Eq. Shortcut
Expand All This command expands all node in the Solution Tree View.
Collapse All This command collapse all node in the Solution Tree View.
Add New Tcl File This command adds a new tcl file from template, as discussed before.
Delete Selected Item This command removes selected item from solution.
Warning: This command could not be undone and hence deleted file never could be recovered!
Tips: Solution startup file could not be removed. If you want to remove a startup file, first set another file as the solution startup file, as described next, and then remove that file.
Rename Selected Item This command renames selected item in Solution Tree View.
Set as Startup File This command sets selected item as startup file.
Run Solution This command runs the solution startup file, not selected or opened item.
Tips: If you double-click on any file in Solution Tree View, that file will open in the editor or if it is already open in the editor, so gets focused!
Tips: Right-click on any item in Solution Tree View will show a pop-up menu that presents some of the above commands. Extra commands are located on the pop-up menu that enabled when you right-click at the solution node, some commands like Add Existing Tcl or Properties.

CypressEditor.UI.Command Explorer

Most famous OpenSees commands included in Command Explorer. They are sorted alphabetically. So if you are looking for a specified command, click on the small reverse triangle , called Option, for a pop up menu.
Then type the command that you are looking for and after that, Command Explore will sort based on your search pattern. Also you can clear filter by using Clear Filter command.
There is an useful command too. Choose Selected Item command will write the selected command from Command Explorer to the editor, if editor contains at least one open file. Please note that the selected command will be written at the caret position.
You may need to complete the command by filling the required arguments.
When you select an item from Command Explorer, then, some proportional note about that command will display on the Command help pane.

Request

We try to add most famous OpenSees commands to the Command Explorer and know this is not including all of them. Please help us to improve the commands list and tell us what commands are lost.

Contact us

CypressEditor.UI.Command Help

Command Help is a very easy and simple help topic for OpenSees commands that are selected from Command Explorer. When you select (click) a command from Command Explorer, related description, syntax and arguments of that command will display in Command Help. as well as, a link to the OpenSees Wiki page of that command is included. If you click on the link, the page of selected command will open on a built-in browse. Thus, even if a command syntax was changed, when user refer to the command page, will know about changes. Here is a full view of the program

CypressEditor.UI.Menu.Run Menu

You could run your solution with two different modes:
  • Current file that is open in editor F5
  • Solution startup file, may be open or not, Ctrl + F5
These modes help you when you are working in big solution with several files. Consider that you defined Section in a file named WHSection.tcl and the startup file of your solution is DampedConcShW.tcl. By now, WHSection.tcl is open in the editor. So, if you use F5 for running the solution, WHSection.tcl will be run, but if you use Ctrl + F5, the DampedConcShW.tcl will be run.

CypressEditor.UI.Menu.Tools Menu

This menu contains some commands that control the program environment.
Command Description Eq. Shortcut
Define Custom Template This command allows you to define your own template and use it when you want to add a new tcl file to your solution. Also , you could update or remove your templates. You can define new template by clicking on Add New Template. Then, Define new template dialog will be displayed.
  • Give a name to your template
  • Add a description to your template
  • Write your own code at the content box. All things that you left here, will be automatically added to new tcl files that uses this template.
Change OpenSees.exe Path This command defines the OpenSees.exe path for CypressEditor. CypressEditor does not be able to run tcl files if OpenSees.exe path is not recognized well.
By default, program consider the following path as OpenSees.exe path:

C:\tcl\bin\opensees.exe
You should change this path by using Change OpenSees.exe Path command.
Option Please read CypressEditor.UI.Options section.

CypressEditor.UI.Options

You could control some behavior of CypressEditor here.

CypressEditor.UI.Options.General Tab

Send report on crash
If this option is enabled, program will send us a report on crash situation, with the user's permission of course. This option helps us to debug the application algorithm and fix bugs for the next releases.
Auto save ...
By enabling this option, program will save all open documents at the specified interval.
Save all open items before run
If this option is enabled, when you try to run your file, program automatically saves all un-saved open documents.
Use internal console
You could choose the type of output console. This option allows you to use program internal console.

CypressEditor.UI.Options.Editor Tab

As it's clear, there is only one enabled option.
Show tooltip on ...
As we discussed before, by enabling this option, you will see a tooltip when mouse hovered on a command or keyword

Activate the Program

After installation, you need to activate the program for first use. It is easy, free of charge and takes only 1-5 mins of your time.
First time that you run the program, the following window will be shown and asks you to enter your name and your email address. Please note that the activation email will sent to this email address, thus you should enter a valid email address.
When you finish filling the form, click on Request Code button and you will receive a message:
Paste your activation code in Activation Code Box and click on Activate button.
When you got the following message, it means that your copy of program is activated: